Phrase System Requirements

Here you find the technical requirements to work with Phrase

Phrase is best run on a desktop device. As a cloud service a reliable internet connection and a web browser are needed to connect to and use Phrase.

We recommend to use the following browser:

- six most recent versions of Chrome, Firefox or Edge browser
- two most recent versions of the Safari browser